Guida 12: installare Opera in Ubuntu Linux

Oltre all’immancabile Firefox, browser ormai incluso in quasi ogni distribuzione, è bene sapere che anche Opera è disponibile da ormai diverso tempo per piattaforma Linux. Opera si è sempre contraddistinto per leggerezza, rapidità, facilità d’uso, sicurezza, supporto delle lingue, largo supporto di piattaforme.

Architetture supportate: 32 bit – 64 bit (Ubuntu 10.04 Lucid Lynx).
Versione supportata: Opera 10.60 (changelog).

Ma soprattutto è sempre stato al primo posto per quanto riguarda l’innovazione: primo browser a puntare effettivamente tutto su prestazioni e leggerezza, bacchetta magica (il metodo tuttora migliore di gestione delle password fra i vari browser), pulsanti di chiusura su ogni tab (già da diversi anni), personalizzazione a 360° delle barre e dei pannelli, temi, strumenti di ricerca integrati, modalità tutto schermo (effettiva).

Ultimamente Opera ha stupito il panorama browser con la collaborazione con Nintendo, (la più antica ed esperta casa video-ludica del pianeta), sviluppando per l’appunto il proprio prodotto per le console Nintendo DSi e Nintendo Wii.

Vediamo ora come installare l’ultima versione di Opera in Ubuntu Linux.

(1) Installazione:

scaricare il pacchetto di installazione e salvarlo sulla Scrivania/Desktop:

pacchetto a 32 bit: opera.deb;

pacchetto a 64 bit: opera.deb;

aprire il pacchetto con un semplice doppio click.

Ad installazione ultimata l’utima versione di Opera sarà disponibile dal menù Applicazioni > Internet.

(2) Flash Player:

per l’installazione del plugin Flash Player seguire la Guida 7.

(!) Avvisi:

non commentare se:

– non si sta utilizzando Ubuntu Linux aggiornato all’ultima versione.

37 thoughts on “Guida 12: installare Opera in Ubuntu Linux

  1. era un po’ che stavo pensando di provarlo….e ho preso l’occasione al balzo conoscendo la fonte…….Grazie!
    p.s. Non so mica se “Polymer” ha funzionato……ciao

  2. :D…hei ragazzi un attimo non l’avevo ancora rilasciata…ahahahahah…

    @ ryoma^^:

    ora vedremo di accontentare anche il popolo 64 bit…

    @ ricochet:

    se hai seguito la guida dovrebbe essere abilitato…per verificarlo riapri “qt3 configuration” e disabilita “polymer” vedrai che te ne accorgerai se non è abilitato😉 …

  3. complimenti per la guida su opera , se ti va vorrei inserire un tuo link nel mio blog:

    ubuntufacile.blogspot.com

    se ti va puoi linkarmi pure tu e visto che parliamo tutti e due di ubuntu potremmo collaborare insieme su progetti comuni.

    ciao a presto

  4. Per Francesco
    salve, è possibile contattare l’admin del sito su una qualche e-mail? scusate per il commento insignificante, ma sono stato costretto visto la mancanza della sezione “contattami”. Grazie anticipatamente

  5. Installare Opera non è stato difficile.
    Tuttavia il language file non è compatibile con la versione che ho scaricato: la 9.2.1.
    E questo passi.
    Il problema grosso è che non riesco ad installare FlashPlayer. Quando l’install mi chiede la directory, gli do quella di opera, ma dice impossibile installare.
    Qual’è la directory giusta?
    Come faccio?

  6. @ chinchillart:

    …ehehehe…hai scaricato la versione che è appena uscita ossia la 9.21…tuttavia non hanno ancora aggiornato i language files che sono rimasti alla “vecchia” 9.20…non appena li aggiorneranno, pubblicherò il nuovo language file…e ti avvertirò su questo post…

    …per flash player…entro mercoledì sera aggiornerò la “Guida 7: installare Flash Player in Ubuntu Linux” con una nuova sezione dedicata a Opera…

    …cmq ti preannuncio che userò il buon vecchio metodo manuale:

    …la cartella dovrebbe essere:

    usr/lib/opera/plugins

    …se non esiste creala manualmente da root (terminale > sudo nautilus)…
    …poi scaricati flash per linux come da Guida 7 e copia il file “libflashplayer.so” nella cartella creata…poi riavvia opera…

    Francesco

  7. Pingback: News: anteprima Opera 9.5 (dev) « Ubuntu Bible

  8. Salve Francesco. Nessuno fin’ora è riuscito a darmi una mano per il mio problema e spero vivamente che tu ci riesca. Ho installato Kubuntu feisty con lo spirito di chi prova una cosa nuova (provengo da Ubuntu 6.10). Con lo stesso spirito ho installato opera 9.21! Il problema è che non naviga. Dopo un’attesa lunghissima riesce ad aprire la pagina di Google ma da lì non si sposta. Qualsiasi indirizzo le dia, Opera aspetta lungamente prima di dirmi: “Errore, non è stato possibile connettersi al server remoto” Cosa psso fare? Considera che la rete va benissimo! Il bruttissimo konqueror nvaiga e apt mi installa tutto… Sto impazzendo! Confido in te….

  9. Innanzi tutto ti ringrazio per la velocità con la quale mi hai risposto!!!
    Ho digitato opera da konsole e mi ha dato queste righe:

    ERROR: ld.so: object ‘libjvm.so’ from LD_PRELOAD cannot be preloaded: ignored.
    ERROR: ld.so: object ‘libawt.so’ from LD_PRELOAD cannot be preloaded: ignored.
    X Error: BadDevice, invalid or uninitialized input device 167
    Major opcode: 144
    Minor opcode: 3
    Resource id: 0x0
    Failed to open device
    X Error: BadDevice, invalid or uninitialized input device 167
    Major opcode: 144
    Minor opcode: 3
    Resource id: 0x0
    Failed to open device

    L’archietura è 32 bit.
    Queste libjvm e libawt saranno librerie, immagino… dovrei installarle? come? Grazie infinite!!!

  10. @ mraj:

    …temevo fosse quest’errore…purtroppo è un errore che sta affligendo diversi utenti ubuntu soprattutto con le ultimissime versioni di Opera…tanto che è stato segnalato sia nel launchpad di Opera:

    https://bugs.launchpad.net/opera-browser/+bug/122250

    sia nel launchpad ufficiale di Ubuntu:

    https://answers.launchpad.net/ubuntu/+question/4759

    ti linko il forum di Ubuntu dove avviene la discussione del tuo caso:

    http://ubuntuforums.org/showthread.php?t=401148

    e quello di Opera dove specificano che il problema è legato alle librerie libx11-dev:

    http://my.opera.com/community/forums/topic.dml?id=183923

    non avendo io stesso il problema non posso dirti se le soluzioni proposte funzionino effettivamente…

    in bocca al lupo…

    Francesco

  11. Salve…
    ho un problemino nell’installare Flash Player su Opera..
    premetto che ho appena formattato il pc e installato Kubuntu (provengo da Ubuntu 7.04).
    ho seguito il problema, ma anche se inserisco la directory usr/lib/opera/plugins come directory dei file da installare per plugin, ottengo solo un errore che dice:

    Please enter the installation path of the Mozilla, SeaMonkey,
    or Firefox browser (i.e., /usr/lib/mozilla): /usr/lib/opera/plugins
    dir= /usr/lib/opera/plugins

    WARNING: Please enter a valid installation path.

    e poi mi fa la stessa domanda di prima:

    Please enter the installation path of the Mozilla, SeaMonkey,
    or Firefox browser (i.e., /usr/lib/mozilla):

    ma se metto /usr/lib/opera
    dice che opera non è supportatal…

    ho provato a mettere la directory di firefox, ma mi da lo stesso errore!

  12. @ koalalorenzo:

    …solo se si ha firefox si può usare l’installer come scritto nella guida…se hai opera non puoi utilizzare l’installer ma devi copiare manualmente il file *.so come scritto nella procedura descritta nei commenti precedenti…

    Francesco

  13. ciao,
    cliccando sul language pack mi da una pagina d’errore, se puoi risistemare il link per favore!
    grazie,
    davide

  14. @ davide:

    …grazie mille della segnalazione…c’era linkato un indirizzo mai visto…boh non so come possa essere accaduto…forse wordpress o googlepages…non so…ora funziona cmq…

    …grazie ancora…

    Francesco

  15. Pingback: Guida 12: installare Opera in Ubuntu Linux « Ubuntu Bible

  16. ciao a tutti.
    ho installato flash player per mozzilla e funziona. poi ho copiato il file “libflashplayer.so” ma non funziona: al posto del file flash mi appare un rettangolo grigio..come posso fare?

  17. Ho sempre ritenuto opera un ottimo browser ma come sta accadendo a Firefox nelle ultime uscite pecca per l’ingordigia di Ram.
    Ho appena installato la 9.50 e messa a confronto con epiphany ne esce vincitrice alla grande.
    Aperte 4 tabs a testa e il consumo di opera è di appen a32 mega contro gli 80 di epiphany.

  18. @ ivan:

    …già…anche perchè ephiphany utilizza il motore di rendering di firefox che è quello che pesa maggiormente…speriamo che l’integrazione ephiphany+webkit dia risultati migliori…o che firefox alleggerisca Gecko con la versione 1.9…cmq opera per adesso è una beta è ha ancora parecchi problemi…attendiamo la versione definitiva…

    ciao

    Francesco

  19. Pingback: News: aggiornamento generale guide « Ubuntu Bible

  20. ciao spero di non essere OT

    Ho appena installato Opera 9.50
    nessun problema con il language pack e con il plugin di flash…

    invece non mi vanno i javascript utente…

    nella versione di opera 9.25 per win bastava salvare i js personali in una cartella e nelle opzioni avanzate->contenuti-> opzioni javascript inserire la cartella scelta precedentemente…

    ora ho provato a fare la stessa cosa ma nn funge.
    se qlkuno sa aiutarmi

  21. Pingback: News: aggiornata Guida 12 (installare Opera in Ubuntu Linux) « Ubuntu Bible

  22. Pingback: News: aggiornata Guida 12 (installare Opera in Ubuntu Linux) « Ubuntu Bible

  23. ho seguito la guida e mi funziona quasi tutto benissimo. ti ringrazio molto.
    c’è solo una cosa: sono un utente amd64, e non mi riesce proprio di far andare il plugin java su questo browser. su firefox mi funziona, ma su opera proprio no, sia con ia32-java, sia con iced tea 7. hai qualche suggerimento?

  24. grazie mille…sto per passare ad ubuntu e questa guida è quello che mi serve…ADORO opera e non potevo farne a meno!

  25. Pingback: News: aggionata Guida 12 (installare Opera in Ubuntu Linux) « Ubuntu Bible

  26. Bene, tutto perfetto, solo una domandina da parte di una che usa sempre il terminale per qualsiasi installazione…🙂
    Come mail la stringa
    sudo apt-get install opera
    non va?
    Leggendo qua e là sui vari blog tutti dicono che per Ubuntu Hardy è il comando da seguire ma a me dice che il pacchetto è obsoleto… Qualcuno conosce la stringa corretta? Grazie e ciao🙂

  27. Ho installato Opera. Ottimo browser se non fosse…Se non fosse che quando seleziono immagini e testo per un copiaincolla da Opera a OOo Writer mi copia solo il testo e non le immagini. Non riesco a risolvere il problema. Come si fa?

  28. “spiacente si e verificato un errore” mi scrive sulla schermata nera del video.
    I video direttamente sul youtube.com non li carica ma posso guardarli da altri siti.
    O reinstallato opera 11 e flash plug-in,ma fa lo stesso.
    Ubuntu 11.04 32bit

    Secondo te cosa potrebbe essere?Quale e il commando per resettare le impostazioni di opera?

  29. Installato Opera. Ottimo. Però, quando selezione da pagine internet testo e immagini e incollo – ad esempio in Writer – mi riporta solo il testo e niente immagini.

  30. Dal sito di Google:
    http://www.google.com/intl/it/earth/download/ge/agree.html
    ho selezionato la voce:
    Seleziona il pacchetto da scaricare:
    ho scelto:
    .deb a 32 bit (per Debian/Ubuntu)
    mi ha scaricato nella cartella: “scaricati” questo file:
    google-earth-stable_current_i386.deb
    poi l’ho spostato in una mia cartella
    poi con il tastO dx del mouse ho evidenziato il file:
    google-earth-stable_current_i386.deb
    e dal menu apparso, ho scelto l’opzione:
    ESTRAI QUI
    subito dopo il pc ha generato una ulteriore cartella dentro
    quella che avevo creato e posizionato il file:
    google-earth-stable_current_i386.deb
    dandole il nome dello stesso file di cui sopra:
    google-earth-stable_current_i386
    dentro questa cartella si sono formate le seguenti 4 cartelle:
    DEBIAN, etc, opt, usr
    sono entrato nella cartella: usr
    vedo 2 cartelle:
    bin, share
    sono entrato in bin
    ho trovato il file: google-earth
    con il tasto destro sopra questo file
    e si apre un menu
    scelto la prima voce: APRI
    compare un finestra con le opzioni:
    esegui nel terminale
    mostra
    annulla
    esegui
    ho scelto: ESEGUI (da solo)
    e Google Earth mi parte alla grande
    senza problemi
    anche con il 3D, street view, etcc
    Il mio notebook é un ACER Extensa 5220
    (n.b.) ho anche installato skype, vlc, la mia pen-usb TV della pinnacle mod. 72e-1100 (cosi é scritto sul dorso della penna)
    con una antennina metallica lunga si e no 20-25 cm con base magnetica, applicata alla ringhiera della mia porta finestra ed orientata in una certa posizione.. va alla grande, mi legge moltissimi canali.
    Quelli privati e quelli nazionali, li vedo benissimo
    si possono anche registrare le trasmissioni (pero’ ci devo ancora lavorare per comprendere meglio come devo settare gli orari di registrazioni), ho fatto una prova l’altro giorno e ho scoperto che avevo registrato un parte di un programma.
    Ho attivato il programma: CLIENT BITORRENT TRANSMISSION
    VA ALLA GRANDE … si scarica bene tutto
    Spero che il presente commento possa aiutare altri che come me
    cercano di installare Google Earth
    Un cordiale saluto a tutti
    Milk88 (fausto)

Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...